[WordPress core file modified]


日本語版WordPressとWordfence Securityを利用している環境で[WordPress core file modified]エラーが出力される。

20150125_002筆者の環境では以下のファイルでエラーとなっていた。

  • wp-includes/version.php
  • readme.html
  • wp-config-sample.php

原因と対策

WordPressのオリジナルファイルとサーバ上のファイルに差異がある場合に出力される。
対象ファイルを確認し、日本語環境独自のものであれば無視してよい。

  • version.phpのオリジナルファイルとの差分
# diff version.php.ORG version.php
36,37d35
<
<$wp_local_package = 'ja';
#

「readme.html」および「wp-config-sample.php」については日本語のコメントが挿入されているためエラー検出されているものと思われる。

当該ファイルにウィルスを仕込まれる可能性も否定出来ないため、定期的にファイル改ざんチェックソフトウェアでチェックする方が良いだろう。

Digiprove sealCopyright secured by Digiprove © 2015
ブックマーク へのパーマリンク.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください